Uploaded image for project: 'OpenAM Agents'
  1. OpenAM Agents
  2. AMAGENTS-1759

WPA4 for IIS post data preservation + cdsso returns 404 error

    XMLWordPrintable

    Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 4.1.0
    • 4.2.0.0, 4.1.0-39
    • Web Agents
    • IIS

      Description

      Install IIS agent4 and enable post-data-preservation mode. Submit POST data to protected resource.

      Expected:

      • POST data is submitted onto the protected resource, browser returns 200 status.

      Actual:

      • browser reports 404 error. Agent log shows this message:

      2018-06-27 10:31:16.195 +0200 DEBUG [3236:2416][source/process.c:2691] handle_exit(): replaying preserved data (d32c7847-9895-ff48-ad98-2c8cc8e0396f)
      2018-06-27 10:31:16.195 +0200 DEBUG [3236:2416][source/iis/agent.c:1491] OpenAMHttpModule(): exit status: success (0), HTTP status: 404
      2018-06-27 10:31:16.319 +0200 DEBUG [3236:2416][source/iis/agent.c:1732] OpenAMHttpModule(): request completed.

      ===
      The problem here was manifold - IIS requires a relative path for a sub-request unlike apache (nginx and others work differently). Also taking advantage of newer technology. May be a docs implication (as HTTP_ shouldn't be needed)

        Attachments

          Activity

            People

            mareks Mareks Malnacs
            mareks Mareks Malnacs
            Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: