Uploaded image for project: 'OpenAM Agents'
  1. OpenAM Agents
  2. AMAGENTS-1798

Downgrade apache 22 version on centos 5 to resolve apr compatibility issue

    XMLWordPrintable

    Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 4.1.0-37
    • 4.2.0.0, 4.1.0-40
    • Web Agents

      Description

      Bug description

      _
      startup issues when upgrading to newer versions of the agent
      Starting httpd: httpd: Syntax error on line 1092 of /etc/httpd/conf/httpsd.conf_env10_61: Cannot load /data/WebPolAgent41037/web_agents/apache22_agent/lib/mod_openam.so into server: /data/WebPolAgent41037/web_agents/apache22_agent/lib/mod_openam.so: undefined symbol: apr_file_sync
      _

      How to reproduce the issue

      1. Install webagent using default centos 5 httpd (2.2.3)
      2. startup httpd
      Expected behaviour
      {normal startup}
      
      Current behaviour
      {error as seen above. segmentation faults can also occur}
      

      Work around

      OPTIONAL - If you have a workaround, please put the details here (remove this text)

      Code analysis

      OPTIONAL - If you already investigated the code, please share your finding here (remove this text)

      org.forgerock.$className.java
      need to downgrade build node to use apr 1.3.x on the centos5 apache 22 node.
      

        Attachments

          Issue Links

            Activity

              People

              alex.levin@forgerock.com Alex Levin
              alex.levin@forgerock.com Alex Levin
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: