Uploaded image for project: 'OpenAM Agents'
  1. OpenAM Agents
  2. AMAGENTS-2416

resolve conflicts for depentent external libraries

    XMLWordPrintable

    Details

      Description

      JEE agents depend on a lot of external libraries

      E.g. for Tomcat JEE Agent 5.5.1.0
      slf4j-api-1.7.21.jar
      
      joda-time-2.9.jar
      
      jackson-databind-2.9.5.jar
      
      jackson-core-2.9.5.jar
      
      guice-4.2.2.jar
      
      guava-25.1-android.jar
      
      metrics-json-3.2.5.jar
      
      metrics-core-3.2.5.jar
      
      mail-1.4.jar
      
      json-simple-1.1.1.jar
      
      javax.inject-1.jar
      
      guice-assistedinject-4.2.2.jar
      
      commons-collections-3.2.2.jar
      
      simpleclient_dropwizard-0.0.21.jar
      
      simpleclient_common-0.0.21.jar
      
      jna-platform-4.2.2.jar
      
      jna-4.2.2.jar
      
      httpcore-4.4.10.jar
      
      httpclient-4.5.5.jar
      
      commons-logging-1.1.3.jar
      
      commons-io-2.3.jar
      
      xml-apis-1.4.01.jar
      

       

      This effectively means you can only use the version of those external libraries.

      That's a huge restriction for application developers.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              tony.bamford Tony Bamford
              Reporter:
              bthalmayr Bernhard Thalmayr
              Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: