Uploaded image for project: 'OpenAM Agents'
  1. OpenAM Agents
  2. AMAGENTS-2466

New Policy Cache mode ignores policy status (Active / Inactive)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 5.6.0.0
    • Fix Version/s: 5.6.0.0
    • Component/s: Web Agents
    • Environment:
      OpenAM Web Agent Version: 5.5.0-SNAPSHOT Revision: , Container: IIS 7.5, 8.x, 10.x WINNT 32/64bit (WINNT), Build date: Feb 11 2019 10:29:00

      Description

      New Policy Cache mode ignore policy status (Active / Inactive).

      Steps to reproduce

      1.) Create a policy e.g: http://agent.com:80/index.com / All Authenticated Users / GET | POST
      2.) Change the status for this policy to Inactive
      3.) Enable policy cache mode(set env variables):

      • AM_POLICY_CACHE_MOD=on
      • AM_POLICY_CACHE_DIR=/path/to/policy/files

      4.) Start Agent
      5.) Access agent's protected page http://agent.com:80/index.com and login

      Expected Result

      After login 403 because policy does not allow it

      Observed Result

      200 Access allowed and I can see protected page

      Workaround

      Instead of de-active the policy, delete it

        Attachments

          Activity

            People

            • Assignee:
              nick.james Nicholas James
              Reporter:
              richard.hruza Richard Hruza
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: