Uploaded image for project: 'OpenAM Agents'
  1. OpenAM Agents
  2. AMAGENTS-2616

Java agent installer makes warning messages when JDK 11 is used

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 5.6.0.0
    • Fix Version/s: None
    • Component/s: J2EE Agents
    • Environment:
    • Target Version/s:

      Description

      Java agent installer makes warning messages when JDK 11 is used.

      1.) Be sure that JDK 11 is set for JAVA_HOME
      2.) Execute agentadmin with some parameter, e.g --version

      Observed

      /java_agents/tomcat_agent/bin/agentadmin --version
      WARNING: An illegal reflective access operation has occurred
      WARNING: Illegal reflective access by org.forgerock.openam.sdk.com.google.inject.internal.cglib.core.$ReflectUtils$1 (file:/tmp/5.6.0/java/java_agents/tomcat_agent/lib/jee-agents-installtools-5.6.0.jar) to method java.lang.ClassLoader.defineClass(java.lang.String,byte[],int,int,java.security.ProtectionDomain)
      WARNING: Please consider reporting this to the maintainers of org.forgerock.openam.sdk.com.google.inject.internal.cglib.core.$ReflectUtils$1
      WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
      WARNING: All illegal access operations will be denied in a future release
      --------------------------------------------------------------------------
      AM Policy Agent for:
      Tomcat
      --------------------------------------------------------------------------
      Version: 5.6.0
      Build Date: 20190325
      Build Revision: 6601fbc7f72174b8152c83077249e75f99850164
      

      Expected

      No warning messages, just version output

      /java_agents/tomcat_agent/bin/agentadmin --version
      --------------------------------------------------------------------------
      AM Policy Agent for:
      Tomcat
      --------------------------------------------------------------------------
      Version: 5.6.0
      Build Date: 20190325
      Build Revision: 6601fbc7f72174b8152c83077249e75f99850164
      

      This issue has no effect on functionality

      Workaround

      Ignore this message or Use the JDK 8 for agentadmin.
      e.g:

      JAVA_HOME=/usr/lib/jvm/java-8-oracle && /java_agents/tomcat_agent/bin/agentadmin --version
      

        Attachments

          Activity

            People

            • Assignee:
              tony.bamford Tony Bamford
              Reporter:
              richard.hruza Richard Hruza
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: