Uploaded image for project: 'OpenAM Agents'
  1. OpenAM Agents
  2. AMAGENTS-2829

Java Agents bundle classes from Java SE 8

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 5.0.0.0, 5.0.1.0, 5.5.1.0, 5.6.0.0, 5.0.0.1, 5.0.0.2, 5.0.0.3, 5.0.1.1, 5.1.0.0, 5.5.0.0, 5.0.1, 5.6.1.0
    • 5.6.2.0, 5.7.0
    • J2EE Agents
    • None

    Description

      Tomcat Agent 5.6.1.0 delivers the following jars

      agent.jar
      jee-agents-sdk-5.6.1.0.jar
      jna-4.2.2.jar
      jna-platform-4.2.2.jar
      xml-apis-1.4.01.jar

      Since Agents 5, only Java SE 8 is supported. Please see https://backstage.forgerock.com/docs/openam-jee-policy-agents/5/java-agents-rnotes/#sec-java-requirements

      xml-api is part of Java SE 8 , hence agent should not bundle it.

      Attachments

        Activity

          People

            kamal.sivanandam@forgerock.com Kamal Sivanandam
            bthalmayr Bernhard Thalmayr
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: