Uploaded image for project: 'OpenAM Agents'
  1. OpenAM Agents
  2. AMAGENTS-2840

WebAgent performs AM user REST call , although not needed

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Blocker
    • Resolution: Fixed
    • 5.6.0.0, 5.6.1.0
    • 5.6.2.0, 5.7.0
    • Web Agents

    Description

      Install Apache Web Agent 5.6.1 in Apache http server 2.4

      Configure Web Agent profile

      • SSO only mode
      • no attribute mapping
      • User ID Parameter Type 'session'
      • no password replay mode

      In the sub-realm where the user authenticates do not configured a user data store / identity store.

      Configure LDAP-based authentication as realm-authenticator
      Set 'User profile' to 'ignored' in core auth setting.

      Request Agent protected resource.

      After authentication with demo user, Agent denies access because REST call ...

      GET /am/json/realms/root/users/demo?_fields=Host,sunIdentityUserPassword,UserToken HTTP/1.1
      

      fails with

      REST response from AM
      {"code":400,"reason":"Bad Request","message":"No plug-ins configured for this operation"}
      

      Attachments

        Issue Links

          Activity

            People

              alex.levin@forgerock.com Alex Levin
              bthalmayr Bernhard Thalmayr
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: