Uploaded image for project: 'OpenAM Agents'
  1. OpenAM Agents
  2. AMAGENTS-3623

Investigate solution to problem with upgrading to AM 7.0.0 with earlier versions of the web agent

    XMLWordPrintable

    Details

    • Story
    • Status: Closed
    • Major
    • Resolution: Done
    • None
    • Web Agents

      Description

      Need to consider what to do about the problem with agent properties being changed in AM upgrade and potential problems associated with advanced properties being overriden.

      To recreate this issue the customer would need to do the following steps

      1) Have an agent (any version except 5.7.0) which has a profile in AM (Not AM 7.0.0) and has some advanced properties configured.
      2) The customer then upgrades to AM 7.0.0
      3) The advanced properties are likely to be overriden so the customer will get unexpected results

      Explanation
      ____________

      For web agents less than 5.7.0, the advanced properties will not take precedence over properties configured in the normal way.

      For AM 7.0.0, we have added properties to the standard UI and these properties will have default values. These properties will override the advanced properties and hence cause confusion for some customers.

      Possible solutions
      ___________________

      1) Customers upgrade agent to 5.7.0 before upgrading AM to 7.0.0

      2) We design a script for AM which gives the new properties the correct values based on the advanced properties

      3) We have documentation about this issue for customers who are upgrading to AM 7.0.0

        Attachments

          Issue Links

            Activity

              People

              edward.barker edwardb
              edward.barker edwardb
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: