Uploaded image for project: 'OpenAM Agents'
  1. OpenAM Agents
  2. AMAGENTS-924

3rd party WPA 4.x http parser does not correctly handle http 1.0 / 1.1 mode switching

    XMLWordPrintable

    Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 4.1.0
    • 4.2.0.0
    • Web Agents

      Description

      The http parser used within the WPA4 does not correctly handle switching between http 1.0 and http 1.1 sessions within a single parsing instance. See https://github.com/nodejs/http-parser/issues/75 for details.

      Whilst fixing the 3rd party library is out of scope, we can work around this issue by recreating the parser instance during such a mixed content mode response.

        Attachments

          Activity

            People

            mareks Mareks Malnacs
            spareyc Charles Sparey
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: