Uploaded image for project: 'OpenAM Agents'
  1. OpenAM Agents
  2. AMAGENTS-998

Encountered HTTP 503 after re-installation of agent 4.1.0-24/23

    XMLWordPrintable

    Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 4.1.0
    • 4.2.0.0
    • Web Agents
    • Windows2012 r2 IIS 8.5 , 4.1.0-24 , 4.1.0-23

      Description

      Test case

      #1. installed 4.1.0-24 window WPA

      #2. test and make sure that the agent 4.1.0-24 is working fine.

      #3. uninstalled the 4.1.0-24 web agent using the 2 commands

       .\agentadmin.exe --r agent_1
       .\agentadmin.exe --g
       

      #4. installed 4.1.0-24 window WPA again

      The installation appear to be successful.

      But if you tried to access the protected page, you will encounter HTTP 503

      Service Unavailable
      HTTP Error 503. The service is unavailable.
      

       Workaround

      ===========

      Avoid using this command

      .\agentadmin.exe --g

       

       

        Attachments

        1. 38_applicationHost_working.config
          71 kB
        2. 38_applicationHost.config
          76 kB
        3. applicationHost.config
          73 kB
        4. applicationHost.config.201708232103234
          68 kB
        5. web.config
          0.4 kB

          Activity

            People

            mareks Mareks Malnacs
            sam.phua Sam Phua
            Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: