Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-10306

Broken CREST delete realm endpoint

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 14.0.0-M9
    • Fix Version/s: None
    • Component/s: configurator
    • Labels:
      None
    • Rank:
      1|hzsp7z:

      Description

      The folloeing statement used to work and is how to delete a sub realm according to documentation.

      https://ea.forgerock.com/docs/openam/doc/bootstrap/maintenance-guide/index.html#rest-api-delete-realm

      Trying to delete realm named smartcity2.

      curl --silent --request DELETE --header 'iPlanetDirectoryPro: AQIC5wM2LY4SfcwCBfarSdhBJf63aSrbZR71srrZyDO4eag.*AAJTSQACMDEAAlNLABQtODI1NTI3NDM1OTg3Njc5MDYyOQACUzEAAA..*' --header 'Content-Type: application/json' http://myiot-am.forgerocklabs.net:8080/openam/json/realms/smartcity2
      {
          "code": 404,
          "message": "Resource '\'''\'' not found",
          "reason": "Not Found"
      }'
      

      I see in the XUI the following endpoint with an internal identifier is used when sending a HTTP DELETE for the sub realm smartcity2:

      http://myiot-am.forgerocklabs.net:8080/openam/json/global-config/realms/L3NtYXJ0Y2l0eTI
      

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              stein Stein Myrseth
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: