Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-11348

A J2EE protected application doesn't deploy on Jboss 7

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Expired
    • JEEAgents-3.5.1
    • None
    • j2ee agents
    • Rank:
      1|hztq5b:

    Description

      The agent installation log file and the application web.xml file can be found here: 

      https://drive.google.com/drive/folders/0By1EqoubhkxUTW13UHRhaW9wM3M?usp=sharing

       

      After having modified the war file of the application to protect according to the documentation (https://backstage.forgerock.com/docs/openam-jee-policy-agents/3.5/jee-users-guide#install-jboss7-agent), and then deploying the application in Jboss, the deployment fails with the following error:

      {"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => {"JBAS014671: Failed services" => {"jboss.web.deployment.default-host./tls" => "org.jboss.msc.service.StartException in service jboss.web.deployment.default-host./tls: JBAS018040: Failed to start context"}}}}

       

      After examining the Jboss error log file (server.log), it seems like the agent filter class can not be found when the application starts (while at the same time the agentapp has been deployed automatically and starts correctly). The classpath doesn't seem to be set correctly or it's ignored/overriden possibly, thus leading to the error.

      Also, no setAgentClasspath.sh file were created by the agent installer. Could this be the root cause of the issue ?

       

      Attachments

        Activity

          People

            Unassigned Unassigned
            cgrosjean Cyril Grosjean
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: