Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-11609

Amster export doesn't export all the settings for the services

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 14.0.0
    • Fix Version/s: None
    • Component/s: Amster
    • Rank:
      1|hzu32n:
    • Support Ticket IDs:

      Description

      Bug description

      It appears that the export-config command of amster doesn't export every attribute in the service configuration. For example the "iplanet-am-auth-sleep-interval" has no resourcename specified and has an empty i18nKey, thus the setting's value is never actually exported to Authentication.json file. There is a good chance that there are similar attributes in the various services that are also not exported.

      How to reproduce the issue

      am -k /Users/bjensen/openam/amster_rsa http://openam.example.com:8080/openam
      x --path am5-export --failOnError
      
      • have a look at Authentication.json and try to find the iplanet-am-auth-sleep-interval attribute or anything that remotely resembles it.
      Expected behaviour

      All service attributes are exported regardless of whether they are meant to be displayed on the admin UI.

      Current behaviour

      Certain attributes are missed...

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            peter.major Peter Major [X] (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated: