Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-11737

http.response.headers not populating in audit logs

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 13.5.1, 14.5.0, 7.0.0
    • Fix Version/s: None
    • Component/s: audit logging
    • Labels:
    • Target Version/s:
    • Support Ticket IDs:

      Description

      Bug description

      No audit logging appears for http.response.headers

      How to reproduce the issue

      Use REST to generate a JSON response.  REST requests returns json formatted data which should contain a header of the form, 'Content-type: application/json'

      1. Make sure audit logging is enabled
      2. Make a REST call to an endpoint to get a JSON response
      3. Check the audit logs for a value in the http.response.headers field of the corresponding entry.
      Expected behaviour
      http.response.headers should have at least 'Content-type: application/json'as a Response Header
      
      Current behaviour
      http.response.headers is blank
      

       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                sfraser Sam Fraser
              • Votes:
                0 Vote for this issue
                Watchers:
                9 Start watching this issue

                Dates

                • Created:
                  Updated: