Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-11882

Auth Trees XUI: Edge: When dragging a connection between nodes all the nodes on the way become selected

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 14.5.0
    • Fix Version/s: 6.0.0
    • Component/s: XUI
    • Labels:
    • Environment:
      AM 5.5.0-M17
      Microsoft Edge 14
      Microsoft Edge 15
    • Target Version/s:
    • Rank:
      1|hzuc1r:

      Description

      Bug description

      To connect one node with another in the authentication tree you have to click on the output of one node and drag it to the input of the second node and then drop. When this connection is being dragged over in Edge then some of the nodes that appear to be "in a way" get selected. See attached screenshot.

      How to reproduce the issue

      1. Go to existing authentication tree (can be Example)
      2. Grab and drag a connection from one node to another and then drop
      Expected behaviour
      The nodes should be connected but no nodes should be selected.
      Current behaviour
      Some nodes get selected during the dragging process (see screenshot - it's a result of connecting Start with Failure. As a result Start, Failure and Success nodes got selected during this process - Failure just partially - only the input dot )

       

        Attachments

          Activity

            People

            Assignee:
            petr-felzmann Petr Felzmann
            Reporter:
            joanna.wasilewska Joanna Wasilewska [X] (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: