Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-12096

API explorer example for PUT on /global-config/services/scripting/contexts/{contexts}/engineConfiguration fails

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 6.0.0
    • Fix Version/s: 6.5.0
    • Component/s: API descriptor
    • Labels:
    • Target Version/s:
    • Rank:
      1|hzux3b:
    • Sprint:
      Sprint 2017.15 Curie, Sprint 2017.16 Newton, Sprint 2017.17 Newton, Sprint 2018.1 Newton, Sprint 2018.2 Newton, Sprint 2018.3 Newton
    • Needs backport:
      No
    • Support Ticket IDs:
    • Needs QA verification:
      No
    • Functional tests:
      No
    • Are the reproduction steps defined?:
      Yes and I used the same an in the description

      Description

      Bug description

      The API explorer example for PUT on /global-config/services/scripting/contexts/{contexts}/engineConfiguration fails with a 400 Bad Request as it does not contain the

      'Accept-API-Version: protocol=1.0,resource=1.0' header.

      How to reproduce the issue

      Use the API explorer with a PUT for the mentioned endpoint with the sample data.  In this case use OIDC_CLAIMS in the 'contexts' field in the API explorer parameters section for testing.

      Expected behaviour
      The sample in the API explorer should work
      Current behaviour
      400 Bad Request

      Work around

      Add the header

       

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              sean.oneill Sean ONeill [X] (Inactive)
              Reporter:
              andy.itter Andy Itter
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: