Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-12232

Dynamic registration is not registering token_endpoint_auth_signing_alg, request_object_encryption_alg and request_object_encryption_enc

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 5.5.1
    • Fix Version/s: 6.0.0, 5.5.2
    • Component/s: OpenID Connect
    • Labels:
    • Needs backport:
      No
    • Needs QA verification:
      No
    • Functional tests:
      No
    • Are the reproduction steps defined?:
      Yes and I used the same an in the description

      Description

      Bug description

      If you do a dynamic registration, you won't be able to set the token_endpoint_auth_signing_alg, request_object_encryption_alg and request_object_encryption_enc

      How to reproduce the issue

      Send a dynamic registration request with the json attribute:

      ...  
        "request_object_encryption_alg": "RSA-OAEP-256",
        "request_object_encryption_enc": "A128CBC-HS256",
        "token_endpoint_auth_signing_alg": "ES256",
      ...
      }
      
      Expected behaviour

      You should see in the response:

        "request_object_encryption_alg": "RSA-OAEP-256",
        "request_object_encryption_enc": "A128CBC-HS256",
        "token_endpoint_auth_signing_alg": "ES256",
      
      Current behaviour

      Those attributes are missing and if you check the OAuth2 client in the admin config, it's indeed not set.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                quentin.castel Quentin CASTEL [X] (Inactive)
                Reporter:
                quentin.castel Quentin CASTEL [X] (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: