Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-12495

When delete an identity it is not being removed from the groups

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 5.5.1, 6.0.0
    • Fix Version/s: 6.0.0
    • Component/s: None
    • Labels:
    • Target Version/s:
    • Sprint:
      2018.3 "Quartley" Turing
    • Needs backport:
      No
    • Needs QA verification:
      No
    • Functional tests:
      Yes
    • Are the reproduction steps defined?:
      Yes and I used the same an in the description

      Description

      Bug description

      When remove the identity it will remain being a member of the groups it used to be assigned to

      How to reproduce the issue

      1. Navigate to the Identities > Groups and add new group (test)
      2. Create a user and assign it to the test group, save
      3. Remove a user and confirm
      4. then edit test group
      Expected behaviour
      as I removed a user it should be deleted from groups it was assigned to
      Current behaviour
      the removed user is still a member of a test group
      

      Note:
      This issue is not new and existed in AM 5.5 already (where user was created in the JATO)

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                rich.riley Rich Riley [X] (Inactive)
                Reporter:
                joanna.wasilewska Joanna Wasilewska [X] (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: