Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-12542

amadmin session failover returns unauthorized on first request

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 13.5.0, 13.5.2
    • Fix Version/s: None
    • Component/s: session
    • Labels:
    • Environment:
      CentOS7
      Java 1.8.0_25-b17
      Apache Tomcat 7.0.65

      Description

      Bug description

      Amadmin session failover returns unauthorized on first request. Behavior is different on four server architecture - I see this error in one of three attempts.

      How to reproduce the issue

      Configure 2 servers in site with enabled Session HA Persistence and Failover and use attached session_test.sh to do this:

      1. login amadmin and demo user to 1st server
      2. shut down 1st server
      3. try to get session idle time from 2nd server
      Expected behaviour
      idle time is returned
      
      Current behaviour
      {"code":401,"reason":"Unauthorized","message":"Access Denied"}
      

      Work around

      Checking session idle time from 2nd server and then turning off 1st server will make session of amadmin user known to 2nd server and then it will work.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                lubomir.mlich Ľubomír Mlích
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: