Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-12544

wrong session idle time in session failover scenario

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 13.5.0, 13.5.2
    • Fix Version/s: None
    • Component/s: session
    • Labels:
    • Environment:
      CentOS7
      Java 1.8.0_25-b17
      Apache Tomcat 7.0.65

      Description

      Bug description

      Idle time request will return -1 after server where session was created is turned off.

      How to reproduce the issue

      Create two sites setup with enabled Session HA Persistence and Failover and do following for example by using attached session_test.sh bash script.

      1. log in to AM1 as demo user and admin user
      2. check demo user idle time in AM2, will return value (this step is needed due to OPENAM-12542)
      3. shut down AM1
      4. check demo user idle time in AM2, will return -1 instead of value
      Expected behaviour

      Show idle time in seconds, for example:

      {"idletime":5}
      
      Current behaviour

      Don't return session idle time:

      {"idletime":-1}
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                lubomir.mlich Ľubomír Mlích
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: