Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-12593

Performance drop of ~20% for authorise endpoint

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Critical
    • Resolution: Fixed
    • 6.0.0
    • 6.0.0
    • oauth2, performance
    • Rank:
      1|hzvjjb:
    • 2018.4 "User Testing" Turing
    • No
    • No
    • No
    • No (add reasons in the comment)

    Description

      Bug description

      There has been a performance drop of about 20% on authorise endpoint when compared to 5.5.1

      How to reproduce the issue

      this can be recreated by using attached config file and below test in pyforge:

      ./run-pybot.py -v -c perf -s oidc.oidc -t authorize_load -n OpenAM

      Test AM 5.5.1 AM 5.5.1 AM 6.0.0 AM 6.0.0
        TPS(req/sec) Response Time(ms) TPS(req/sec) ResponseTime(ms)
      Authorise Load  2472.438 3 1977.673 4

      the last sane results recorded was around 2nd Feb..

      latest authorise results are : 1687.986req/sec 

       

      http://openam.example.com:8080/openam/XUI/#login/&realm=%2Fmyrealm&goto=http%3A%2F%2Fopenam.example.com%3A8080%2Fopenam%2Foauth2%2Fauthorize%3Fclient_id%3DclientOIDC%26response_type%3Dcode%26redirect_uri%3Dhttp%253A%252F%252Ffake.com%26scope%3Dopenid%26realm%3Dmyrealm%26nonce%3D1234

      Attachments

        Issue Links

          Activity

            People

              sean.oneill Sean ONeill [X] (Inactive)
              narita.saxena Narita Saxena
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: