Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-12742

Post upgrade creating a subrealm of a subrealm post upgrade results in 500 error

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 6.0.0
    • Fix Version/s: 6.0.0
    • Component/s: upgrade, XUI
    • Labels:
    • Environment:
      ForgeRock Access Management 6.0.0-SNAPSHOT Build 9894bffdd6 (2018-March-27 02:14)
    • Target Version/s:
    • Rank:
      1|hzvnpb:
    • Needs backport:
      No
    • Needs QA verification:
      No
    • Functional tests:
      Yes
    • Are the reproduction steps defined?:
      Yes and I used the same an in the description

      Description

      Bug description

      Post upgrade creating a subrealm of a subrealm post upgrade results in 500 error

      How to reproduce the issue

      • Install AM 5.5.1
      • Create a subrealm
      • Upgrade to AM 6.0.0
      • Create a subrealm of that subrealm
      Expected behaviour

      Sub-subrealm created without error

      Current behaviour
      • 500 Error is displayed without a message
      • At first it appears the sub-subrealm was not created (but it is)
      • The UI then fails to navigate correctly e.g. on Save the dialog does not navigate back to display the realms
      • (The error can be misleading when associated with other failures)

        Attachments

          Activity

            People

            • Assignee:
              pilar.gomez Pilar Gomez [X] (Inactive)
              Reporter:
              AndrewVinall Andrew Vinall
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: