Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-12901

Webhooks and trees fail to clone to subrealms - 400 Error

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 6.0.0
    • Fix Version/s: 6.0.0
    • Component/s: trees
    • Labels:
    • Environment:
      ForgeRock Access Management 6.0.0-SNAPSHOT Build f219ef7d5b (2018-April-13 02:16)
    • Target Version/s:
    • Needs backport:
      No
    • Needs QA verification:
      No
    • Functional tests:
      Yes
    • Are the reproduction steps defined?:
      Yes and I used the same an in the description

      Description

      Bug description

      Webhooks and trees fail to clone to subrealms

      How to reproduce the issue

      • Create a tree with a Register Logout Webhook node
      • Create a subrealm
      Expected behaviour
      • When the subrealm is created
        • The webhooks are cloned
        • The trees are cloned
      Current behaviour
      {"code":400,"reason":"Bad Request","message":"Data validation failed for the attribute, Webhook Name"}
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kajetan.hemzaczek Kajetan Hemzaczek
                Reporter:
                AndrewVinall Andrew Vinall
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: