Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-13222

Active sessions not appearing in AM console

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 14.0.0, 6.0.0.2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Rank:
      1|hzw553:
    • Support Ticket IDs:

      Description

      Bug description

      When authenticating using the LDAP module no user sessions are appearing in the session tab within AM console

      Realm > realm name > Session > Search for a user you have logged in with. 

      How to reproduce the issue

      1. Install DS with some dummy users.
      2. Configure LDAP module in AM to point to it. 
      3. Set profile -> Ignored
      4. Authenticate to LDAP module as one of the users in DS who doesn't have a profile in AM
      5. Successfully get a token in the response.
      6. Check Session tab on admin console, nothing there. 
      Expected behaviour
      When logging in with a standard user this should be refelected in the AM console as a current active session
      Current behaviour
      When logging in with a standard user, this user should be visible within the AM console as an active session 
      

      Work around

      Change the profile setting to create user dynamically. Realm > realm name > Authentication > Settings > User Profile > True

       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                eliot.kerslake Eliot Kerslake
              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: