Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-13230

Upgrade fails after removing the embedded ldap class

    Details

    • Target Version/s:

      Description

      Bug description

      The embedded DJ properties still exist in old config, but they have been removed in AM 6.5.0, making upgrades fails
      Suspected culrit:
      https://stash.forgerock.org/projects/OPENAM/repos/openam/pull-requests/5053/overview

      How to reproduce the issue

      1. Install am 5.5.x
      2. Upgrade to current master (using the wizard)
      Expected behaviour

      Upgrade succeeds

      Current behaviour

      Upgrade fails

      Work around

      None

      Code analysis

      We probably need upgrade steps to remove/change the old embedded ldap config (refer to the PR in the description).
      Some version issue have been seen as well -> check OPENAM-12912

        Attachments

          Activity

            People

            • Assignee:
              pilar.gomez Pilar Gomez [X] (Inactive)
              Reporter:
              pilar.gomez Pilar Gomez [X] (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: