Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-13324

/users/{user}/devices/trusted REST queryFilter expression does not work and acts as "true"

    Details

    • Sprint:
      AM Sustaining Sprint 58
    • Story Points:
      2
    • Needs backport:
      No
    • Support Ticket IDs:
    • Needs QA verification:
      No
    • Functional tests:
      No
    • Are the reproduction steps defined?:
      Yes and I used the same an in the description

      Description

      Bug description

      When using the /users/{user}/devices/trusted REST endpoint the queryFilter expression does not work and acts as "true" and returns all.

      How to reproduce the issue

      1). Set up a chain that contains the modules specified here:

      https://backstage.forgerock.com/docs/am/6/authentication-guide/#device-id-match-hints

      2). Login as the end user so a device profile is created for that user.

      3). Use the API explorer and find /users/{user}/devices/trusted

      4). Enter the user name that should now have profile info that's returned from this endpoint and set _queryFilter true.  The results should be returned as expected.

      5). Change the _queryFilter text box to a key with an invalid value, eg:

      uuid eq "test"

      ...note that the results are still returned which suggests that the query filter does not work as it would be expected to see no results in this case.

      Expected behaviour
      Results returned filtered on specified value
      
      Current behaviour
      All results returned
      

       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                lawrence.yarham Lawrence Yarham
                Reporter:
                andy.itter Andy Itter
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: