Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-13398

SAML SSO broken after performing Session upgrade

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 14.0.0, 14.1.0, 14.1.1, 14.5.0, 5.5.1, 6.0.0
    • Fix Version/s: 6.0.1, 5.5.2
    • Component/s: SAML
    • Labels:
      None
    • Support Ticket IDs:

      Description

      Bug description

      SAML based SSO breaks after a session upgrade was triggered

      How to reproduce the issue

      1. configure AM
      2. configure 2 auth-chains in realm '/'
      3. configure hosted IdP in CoT 'TestCoT' in realm '/'
      4. configure some SP
      5. configure remote SP in CoT 'TestCoT' in realm '/'
      6. Perform authentication via auth-chain1
      7. Perform SP-initiated SSO without a specific AuthContext
      8. Perfrom XUI based 'session upgrade' via auth-chain2
      9. Perform SP-initiated SSO without a specific AuthContext
      Expected behaviour
      SP-initiated SSO flow should succeed
      
      Current behaviour
      SSO (500 error is returned, com.sun.identity.saml2.common.SAML2Exception: IDP Session is NULL)
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                adam.heath Adam Heath
                Reporter:
                bthalmayr Bernhard Thalmayr
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: