Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-13793

Building AM with the suppress-upgrade causes an exception

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 6.5.0
    • Fix Version/s: 6.5.0, 6.0.1, 5.5.2
    • Component/s: None
    • Labels:
      None

      Description

      Steps to reproduce

      1. Set up a default AM with configuration:

      • Build AM
      • Start AM
      • Configure AM with default configuration

      2. Re build with suppress-upgrade

      • Build AM with -Psuppress-upgrade
      • Start AM

      Expected: AM starts without checking that an upgrade is needed
      Actual: Use is shown the upgrade page and the exception in the log is:

      org.forgerock.openam.upgrade.UpgradeException: Unable to parse product versions for comparison. Current: ForgeRock Access Management 6.5.0-SNAPSHOT Build 2ae8594837 (2018-October-15 09:35) war: 
      	org.forgerock.openam.upgrade.VersionUtils.isVersionNewer(VersionUtils.java:103)
      	org.forgerock.openam.upgrade.VersionUtils.isVersionNewer(VersionUtils.java:90)
      	com.sun.identity.setup.AMSetupManager.isVersionNewer(AMSetupManager.java:72)
      	com.sun.identity.setup.AMSetupFilter.isConfigStoreDown(AMSetupFilter.java:162)
      	com.sun.identity.setup.AMSetupFilter.doFilter(AMSetupFilter.java:115)
      	org.forgerock.openam.audit.context.AuditContextFilter.doFilter(AuditContextFilter.java:46)
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jay.bowers Jay Bowers
                Reporter:
                jay.bowers Jay Bowers
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: