Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-14004

AM should support agents deployed to the root context (/), not just /openam

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 14.5.0, 6.0.0, 6.5.0
    • Fix Version/s: 6.5.1, 7.0.0
    • Component/s: None
    • Environment:
      OPENAM 6.5.0-M12
    • Sprint:
      2018.16 - Tin
    • Needs backport:
      No
    • Needs QA verification:
      No
    • Functional tests:
      Yes
    • Are the reproduction steps defined?:
      Yes but I used my own steps. (If so, please add them in a new comment)

      Description

      There has been a change to the Cloud Deployment so that we no longer have the naming context

      so for example http://openam.example.com:8080/openam/UI/Login would become

      http://openam.example.com:8080/UI/Login.

      Unfortunately this does not work well with the Agents. When trying to create a new web Agent without the naming context we get and error
      "The URL must be entered in the format 'protocol://host:port/deploymentUri'."

      As well as this issue there are a number of properties which are created based on this value so they may need to be changed.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                peter.major Peter Major [X] (Inactive)
                Reporter:
                edward.barker edwardb
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: