Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-14146

administrative authentication is not triggered for XUI-based console

    XMLWordPrintable

    Details

    • Bug
    • Status: Open
    • Major
    • Resolution: Unresolved
    • 13.0.0, 13.5.0, 13.5.1, 13.5.2, 14.0.0, 14.1.0, 14.1.1, 14.5.0, 14.5.1, 5.5.1, 6.0.0, 6.0.0.1, 6.0.0.2, 6.0.0.3, 6.0.0.4, 6.0.0.5, 6.5.0, 6.0.0.6
    • None
    • console, XUI
    • Rank:
      1|hzxaxz:

      Description

      Bug description

      XUI based console triggers realm-based authentication instead of administrative authentication

      How to reproduce the issue

      1. Configure (Open)AM
      2. define an auth-chain which does not use DataStore authentication
      3. select this auth-chain for "Organization Authentication Configuration" in root realm
      4. Re-Login to (Open)AM console
      5. Wait until administrative SSO session times out (or clear the SSO tracking cookie)
      6. Access (Open)AM console
      7. If authentication "pop up" appears try to authenticate as 'amadmin'
      Expected behaviour
      Authentication should be successful so that (Open)AM console session could be proceeded.
      
      Current behaviour
      Authentication fails
      

      Work around

      enter ..../AM-context-root/console again

      Difference to JATO-based console

      When the SSO session times out in an JATO-based view, administrative authentication is triggered correctly.

        Attachments

          Activity

            People

            Unassigned Unassigned
            bthalmayr Bernhard Thalmayr
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated: