Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-14150

Cannot log in using email address with LDAP Decision Node

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 6.5.0
    • Fix Version/s: None
    • Component/s: authentication
    • Labels:
      None
    • Rank:
      1|hzxb5z:

      Description

      Bug description

      Authentication fails with Not Found error when using authentication trees configured with mail as an attribute used to search for a user to be authenticated.

      How to reproduce the issue

      1. Install AM 6.5
      2. Create realm: myRealm
      3. Create an authentication tree: myTree
      4. Configure a Page Node containing Username Collector and Password Collector Nodes.
      5. Link the Page node to an LDAP Decision Node
      6. Add mail attribute to Attributes Used to Search for a User to be Authenticated field
      7. Add demo@example.com as the Email Address for the demo user
      8. Login via the tree e.g. http://am.example.com:8080/access/XUI/?realm=myRealm&service=myTree#login
      Expected behaviour
      User is redirected to the profile page
      
      Current behaviour
      A Not found error is displayed. See attachment.
      

      Work around

      None identified.

       

        Attachments

        1. Notfound.png
          Notfound.png
          75 kB
        2. tree.png
          tree.png
          238 kB

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                tim.chandler Tim Chandler
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: