Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-14849

Insufficient debug logging in Scripted authentication module

    XMLWordPrintable

    Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: Won't Fix
    • 13.0.0, 13.5.0, 13.5.1, 13.5.2, 14.0.0, 14.1.0, 14.1.1, 14.5.0, 14.5.1, 5.5.1, 6.0.0, 6.0.0.1, 6.0.0.2, 6.0.0.3, 6.0.0.4, 6.0.0.5, 6.5.0, 6.0.0.6, 6.5.0.1, 6.5.1, 6.5.0.2
    • None
    • authentication
    • Oracle JDK 1.8.0_201-b09
      Apache Tomcat/9.0.8
      AM 6.5.1
    • Rank:
      1|hzy5tb:
    • AM Sustaining Sprint 84, AM Sustaining Sprint 85, AM Sustaining Sprint 86
    • 2

      Description

      Bug description

      No message level debug information about what's going on in the scripted authentication module

      How to reproduce the issue

      Use scripted authentication module with server side script

      Expected behaviour
      Authentication log should show log statements which helps to troubleshoot customer issues. Issues must be solvable by only inspecting the debug log.
      
      Current behaviour
      Insufficient debug logging
      

       

      Code analysis

       

      org.forgerock.openam.authentication.modules.scripted.Scripted.java
      ...
      

        Attachments

          Activity

            People

            Unassigned Unassigned
            bthalmayr Bernhard Thalmayr
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 16h
                16h
                Remaining:
                Remaining Estimate - 16h
                16h
                Logged:
                Time Spent - Not Specified
                Not Specified