Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-14893

XUI displays multiple error messages when an authentication session times out

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 6.0.0.6
    • Fix Version/s: None
    • Component/s: XUI
    • Labels:
    • Sprint:
      AM Sustaining Sprint 63
    • Story Points:
      2
    • Support Ticket IDs:

      Description

      Bug description

      If a user leaves their browser on the login page for too long (longer than the timeout) then they see two error messages, one after another. The first message says their authentication times out. The second says "Bad Request".

      How to reproduce the issue

      1. Configure a simple Tree with DataStore decision node and user/pwd collectors
      2. Navigate to the login page
      3. Wait 5 min (i.e. the default auth session timeout for Trees)
      4. Attempt to authenticate
      Expected behaviour
      One error message 
      Current behaviour
      Timeout error, followed by a 'bad request' error. 
      

      Work around

      Customer fixed the issue with the 400 response from the REST call I am attaching the fix that customer put in to fix the issue.

      Code analysis

      See attachment

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              jordan.kasper Jordan Kasper [X] (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: