Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-15199

AM installed on WAS 8.5.5.x is incompatible with WebAgents 5.x

    XMLWordPrintable

    Details

    • Rank:
      1|hzyn73:
    • AM 2019.11 - Crossbow
    • No
    • No
    • No
    • No (add reasons in the comment)

      Description

      As Per:
      https://developer.ibm.com/answers/questions/389316/does-websphere-full-profile-8556-support-websocket/

      WebSphere Application Server full profile 8.5.5.x does not support WebSockets, only the Liberty 8.5.5.4 (and higher) profile which using SDK 7.0.
      

      This means you cannot use Agent 5.x in conjunction with AM5 (or AM6) installed on WAS versions with that incapability. This poses a problem for who upgrade to AM5.5+ with the idea that they can use the latest agents, thus meaning they have to upgrade containers. So for anyone upgrading, they will then have problems upgrading / simultaneously using different agents which commonly people do within transition periods/migration paths.

      We don't state much around WAS limitations in the documentation and we should.

        Attachments

          Issue Links

            Activity

              People

              cristina.herraz Cristina Herraz [X] (Inactive)
              jeremy.cocks Jeremy Cocks
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: