Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-15214

Auth Tree - Clicking save with no changes causes render problem with node attributes inside page node

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 7.0.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:

      Description

      Bug description

      In an Authentication tree, if you have nodes inside page nodes, sometimes the node attributes do not display at all on the panel on the right side (picture attached). 

      How to reproduce the issue

      1. Create a simple tree- any type of node inside a page node should be sufficient (see screenshot)
      2. click the page node, and without making any changes, click save.
      3. Click on the node inside the page node (username in the screenshot)- you will notice the node name attribute is missing in the right panel, like in the screenshot. The only way I've found to get it back is to leave and come back to the page, or refresh

       

      Expected behaviour
      Should be able to see the node attributes in the right panel
      
      Current behaviour
      Can not see the node attributes
      

      Work around

      Refresh the page

        Attachments

          Activity

            People

            • Assignee:
              demetrio.urquidi Demetrio Urquidi
              Reporter:
              lindsey.miller Lindsey Miller
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: