Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-15307

Trees Example is not working as expected OOTB to ?service=Example

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 6.5.2
    • Fix Version/s: 6.0.1, 6.5.3, 7.0.0, 5.5.2
    • Component/s: trees
    • Labels:
    • Sprint:
      AM Sustaining Sprint 66
    • Story Points:
      3
    • Needs backport:
      No
    • Support Ticket IDs:
    • Verified Version/s:
    • Needs QA verification:
      Yes
    • Functional tests:
      No
    • Are the reproduction steps defined?:
      Yes and I used the same an in the description

      Description

      Bug description

      Trying to isolate the difference between chains and trees or why is it acting different here?

      How to reproduce the issue

      Setup 

      1. Install AM 6.5.2 OOTB (using embedded DS for all DataStores)
        ADD REALM! 
            NAME! subscribers
            DNS: subscribers.example.com
      2. ADD Identity
            NAME! anonymous
             PW! changeit
      3. ADD AuthN Module 
            NAME! "Anonymous-41902"
             TYPE! Anonymous Valid Anon
             Users: demo ahale anonymous
      4. ADD Chain
             NAME! "41902-Anonymous"
              ADD Module: Anonymous-41902
              REQUIRED Save Changes

      Confirm you can login to subscribers long and short URLs:

      Test (adjust URI to you env)

      1. Put AM in debug=Message, clear cookie-cache, shutdown server, clear logs and restart.
      2. Paste URL to Anonymous
        Login anonymous user to Anonymous AuthN Module
        https://subscribers.example.com:8443/am6520/?service=41902-Anonymous
        This will land on the anonymous User profile. DO NOT LOGOUT.
      3. Paste URL to Tree
        Login demo user to Example Tree
        https://subscribers.example.com:8443/am6520/?service=Example
        This will fail (see screenshot). DO NOT LOGOUT.
      4. Paste URL to LDAP
        Login demo user to default ldapService
        https://subscribers.example.com:8443/am6520/?service=ldapService
        This will land on the demo User profile.  LOGOUT, shutdown and check the <debug> logs.
      Expected behaviour
      User logs in as expected via the service=NAME!
      
      Current behaviour
      The default OOTB ldapService and added Anonymous Modules land on User profile page as expected, but the Example OOTB Tree Fails.

      Work around

      Unknown

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                sachiko Sachiko Wallace
                Reporter:
                ashley.hale Ashley Hale
              • Votes:
                0 Vote for this issue
                Watchers:
                9 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: