Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-15448

serverconfig seen in drop down for create new authentication module

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Not a defect
    • Affects Version/s: 5.5.1, 6.0.1, 5.5.2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Target Version/s:
    • Rank:
      1|hzz2yf:

      Description

      Bug description

      serverconfig is shown multiple times in the drop down for Authentication Module type when trying to create a new Authentication module.

      How to reproduce the issue

      1. Deploy AM.  Embedded config and user store.
      2. Login in as amadmin.  In top level realm, navigate to Authentication and then Modules.  Choose to Add a new authentication module.
      3. Click to select the type of authentication module.
      Expected behaviour
      The list of authentication module types is shown.
      Current behaviour
      'serverconfig' is shown multiple times.  See attached image.

      Work around

      It is possible to select one of these and progress to create the relevant authentication module.  Its a guess though as to which type is needed.

      After a server restart, the list of types is populated as expected.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            lawrence.yarham Lawrence Yarham
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: