Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-15560

WebAuthN Node not upgrade from 6.5.2

    Details

    • Target Version/s:
    • Rank:
      1|hzwmzz:
    • Support Ticket IDs:

      Description

      Bug description

      The webauthn node is not upgraded with new schema (or if it is upgraded if you fix this) does not have logic to make it continue to work on 7.0.0

      How to reproduce the issue

      1. Install 6.5.2.x
      2. Create some WebAuthN nodes (or ensure it works first and tested)
      3. Now Tomcat
      4. Update to AM7.0.0 Snapshot (Oct 2019) by replacing openam.war with this
      5. Perform the upgrade
         
        Expected behaviour
        WebAuthn should work
        
        Current behaviour
        WebAuthn Broken (not working) and also the new UI (origins) are not seen
        

      Work around

      None

      Code analysis

      The NodesPlugins for 6.5.2 is the same as the current AM 7.0.0 version. Also with the new origins being required it will always fail and the upgrade does not populate this. Should this be "*" for the origins (or an empty list) be ignore to preserve old behaviour. Also, amster export/import needs consideration too (since origins is required and so old amster may not work)

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                philip.anderson Philip Anderson
                Reporter:
                chee-weng.chea C-Weng C
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: