Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-15792

Redirect loop when logging in with sub-admin

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 7.0.0
    • Fix Version/s: None
    • Component/s: console, XUI
    • Labels:
    • Target Version/s:

      Description

      Bug description

      Redirect loop when logging in with a sub-admin

      How to reproduce the issue

      It is possible to assign a group privileges to administer a given realm. When this is the case and a user from within that group logs into the realm, they should then be presented with the Admin Console.

      To reproduce

      • Log into root realm as amadmin and create a new group
      • Create a user and add them to that group
      • Go the the 'Privileges' tab within the realm
      • Choose newly created group, and add all available privileges
      • Log out of OpenAM
      • Log in with new user
      Expected behaviour

      Get redirected to openam/console

      Current behaviour

      When I try to log in with this "sub-admin" I get stuck in a redirect loop between /XUI/?realm=%2F#login and /ui-admin/?realm=%2F .

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                jake.feasel Jake Feasel
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: