Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-15848

SMS service schemas invalid after upgrade

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 7.0.0
    • Fix Version/s: 7.0.0
    • Component/s: sms, upgrade
    • Labels:
    • Target Version/s:
    • Needs backport:
      No
    • Needs QA verification:
      No
    • Functional tests:
      No

      Description

      Bug description

      Upgrading from gcr.io/forgerock-io/am:7.0.0-b33f5b14758a42cfc02c2e36b084955d5453bc74 to gcr.io/forgerock-io/am:7.0.0-4ea6ee69db9801cf2321c3dded19c6f7e9a0dbd2 leaves AM's SMS schema in an invalid state.

      How to reproduce the issue

      1. Run a default install of gcr.io/forgerock-io/am:7.0.0-b33f5b14758a42cfc02c2e36b084955d5453bc74 and then upgrade to gcr.io/forgerock-io/am:7.0.0-4ea6ee69db9801cf2321c3dded19c6f7e9a0dbd2
      2. In the admin console, attempt to navigate to configure > global services
      Expected behaviour
      Global services are listed
      
      Current behaviour
      Internal server error
      

      Work around

      N/A

      Code analysis

      See https://forgerock.slack.com/archives/CSA1V6WG1/p1579183263248700

        Attachments

          Activity

            People

            • Assignee:
              phillcunnington Phill Cunnington
              Reporter:
              craig.mcdonnell Craig McDonnell
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: