Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-16152

After upgrade, new Identity page has duplicate 'new identity' field and email address does not save

    Details

      Description

      After an upgrade from 6.0.0.7, the Identities -> New Identity page is displaying more fields that previously, has two 'User ID' fields, and specifying an email address does not result in it being saved when the identity is created.

       

      Reproduction steps:

      1. AM deployment 6.0.0.7, embedded config and user store.
      2. Upgrade to AM 7.0.0 snapshot war.
      3. Login as amadmin.  Navigate to top level realm, Identities.
      4. Click to Add new identity.
      5. Observe the fields present on the page.  Previously there were fewer fields on the create page (user id, password and email address if I remember correctly) - not sure if addition of more is intentional here or not.
      6.  Fill out the fields on the page (I tested email address, both user id fields and password).  Save to create the identity.
      7. On the edit identity displayed back, the email address is blank.  I've not tested other fields to see if these have saved as expected or not.

        Attachments

          Issue Links

          There are no Sub-Tasks for this issue.

            Activity

              People

              • Assignee:
                michael.carter Michael Carter
                Reporter:
                lawrence.yarham Lawrence Yarham
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: