Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-16177

Unmet lodash dependency warning when building openam-ui-ria module

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 6.5.3
    • Fix Version/s: 6.5.3
    • Component/s: XUI
    • Labels:
    • Target Version/s:
    • Rank:
      1|i00t93:
    • Sprint:
      AM Sustaining Sprint 74
    • Story Points:
      2
    • Needs QA verification:
      No

      Description

      When building the openam-ui module from the sustaining/6.5.x branch - an unmet dependency warning can be seen for lodash.

      Performing an `npm list lodash` against the openam-ui-ria module you can see the following in the output indicating that it is expecting a version of lodash greater than 4.17.15

      ...
      ├─┬ sinon@5.0.10
      │ └─┬ nise@1.5.2
      │   └─┬ @sinonjs/formatio@3.2.2
      │     └─┬ @sinonjs/samsam@3.3.3
      │       └── UNMET DEPENDENCY lodash@^4.17.15
      ...

       

      This should be resolved correctly

        Attachments

          Activity

            People

            Assignee:
            adam.heath Adam Heath
            Reporter:
            adam.heath Adam Heath
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: