Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-16290

Unable to use DeviceId Nodes in Tree

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 7.0.0
    • Fix Version/s: None
    • Component/s: trees
    • Labels:
    • Environment:
      ForgeRock Access Management 7.0.0-SNAPSHOT Build eb2ce48b2fa6f42f9928acdb5b2a22f7ff988865 (2020-May-26 22:14)

      Description

      Bug description

      Authentication fails when using a tree containing a "Device Profile Collector" + "Device Profile Save" node.

      How to reproduce the issue

      • Create a tree __ a "Username Collector", "Device Profile Collector" and "Device Profile Save" node.
      • Attempt to login
      • e.g. joanna.example.com:8080/openam/XUI/#login/&authIndexType=service&authIndexValue=DeviceTree
      Expected behaviour
      • Login is successful
      • A Device Profile is saved
      Current behaviour
      • A second and anonymous text field is displayed (after the username has been input)
      • The text field is associated with a `DeviceProfileCallback`
      •  callbacks	[…]
        0	{…}
        type	DeviceProfileCallback
        output	[…]
        0	
        name	metadata
        value	true
        1	{…}
        name	location
        value	false
        2	{…}
        name	message
        value	
        input	[…]
        0	{…}
        name	IDToken1
        value	
      • Login fails

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                AndrewVinall Andrew Vinall
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: