Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-16555

(audit) logging does not tell which policy allowed or denied a resource request

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 13.0.0, 13.5.0, 13.5.1, 13.5.2, 14.0.0, 14.1.0, 14.1.1, 14.5.0, 14.5.1, 5.5.1, 14.1.1.1, 14.1.1.2, 14.1.1.3, 6.0.0, 6.0.0.1, 6.0.0.2, 6.0.0.3, 6.0.0.4, 14.1.1.4, 6.0.0.5, 14.1.1.5, 14.1.2.2, 6.5.0, 6.0.0.6, 6.5.0.1, 6.0.0.7, 14.1.2.3, 6.5.1, 6.5.0.2, 14.1.2.4, 6.5.2, 6.5.2.1, 6.5.2.2, 6.5.2.3, 14.1.1.8, 5.5.2, 14.1.2.5, 7.0.0, 14.1.2.11
    • Fix Version/s: 5.5.3, 6.0.1, 6.5.3, 7.1.0, 7.0.1
    • Component/s: audit logging, policy
    • Labels:
    • Sprint:
      AM Sustaining Sprint 78
    • Story Points:
      2
    • Support Ticket IDs:
    • Needs QA verification:
      No
    • Functional tests:
      No
    • Are the reproduction steps defined?:
      Yes and I used the same an in the description, Yes but I used my own steps. (If so, please add them in a new comment)

      Description

      Bug description

      It's not logged which policy denied/allowed a resource request.

      How to reproduce the issue

      1. Configure AM
      2. Configure some URL policies
      3. Perform REST based policy evaluation
      4. Inspect AM log files
      Expected behaviour
      There should be one log message which tells which policy allowed / denied the resource request.
      
      Current behaviour
      There is no log message which tells which policy allowed / denied the resource request.
      

        Attachments

          Activity

            People

            • Assignee:
              lawrence.yarham Lawrence Yarham
              Reporter:
              bthalmayr Bernhard Thalmayr
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: