Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-16816

Discrepancy found in AM6 + Older Agents compatibility docs.

    Details

    • Rank:
      1|i026ov:

      Description

      Bug description

      Discrepancy found in AM6 + Older Agents compatibility docs.

      AM6 release notes(https://backstage.forgerock.com/docs/am/6/release-notes/index.html#changes) states

       

      Changes to Web Agents and AM Interoperability Requirements
      AM 6 requires Web Agents 5.x to be in version 5.0.1 or higher. Upgrade any web agent in version 5 before upgrading to AM 6.
      

       

      Where as KB https://backstage.forgerock.com/knowledge/kb/article/a71812526 states

       

      AM6 is compatible with WPA 4.x and JEE 3.5.x with profile changes.
      
      AM 6 Yes (5.0.1 or later) Yes *
      New Agents Profiles on AM 6 are not compatible with Web Agents 4.x by default and will require setting the AM Login URL and AM Logout URL to work with AM 6. Additionally, the experimental REST login mode that was introduced in Web Agents 4.1.0.30 will not work with AM 6.0.0.x. See How do I configure AM 6.0.0.x to work with older policy agents (Web 4.x and JEE 3.5.x)? for details. 
      

       

      Appears docs and KB needs update as we found couple of bugs with AM6 + WPA 4.x/JEE 3.5.x  OPENAM-16357 and AMAGENTS-2116.

      The limitations should be added to the docs and KB to avoid confusions.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              kamal.sivanandam@forgerock.com Kamal Sivanandam
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: