Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-17052

ssoadm - sub-command 'delete-entity' does not remove entity from CoTs

    XMLWordPrintable

    Details

    • Bug
    • Status: Open
    • Major
    • Resolution: Unresolved
    • 6.5.2.2
    • None
    • SAML, ssoadm
    • None
    • Oracle JDK 1.8.0_201
      Apache Tomcat 9.0.8
      AM 6.5.2.2
      SSOAdminTools 'OpenAM 14.1.2.13'
    • Rank:
      1|i02qxb:

      Description

      Bug description

      Using 'ssoadm delete-entity' leaves system in an inconsistent state

      How to reproduce the issue

      1. Configure AM
      2. Setup SSOAdminTools (AM-SSOAdminTools-5.1.2.13.zip)
      3. Configure some realm
      4. Configure some Circle Of Trusts
      5. Configure hosted IdP in that CoTs
      6. Import some remote SP entity data
      7. Add SP entity to the CoTs (e.g. via AM console)
      8. Use 'ssoadm delete-entity' to delete the remote SP entity
      Expected behaviour
      remote SP entity should also be removed from all CoTs
      
      Current behaviour
      Remote entity is still a member of the CoTs, leaving the system in an inconsistent state.
      

      This seems to be some regression as in the past 'delete-entity' removed the entities from the CoTs as well.

        Attachments

          Activity

            People

            Unassigned Unassigned
            bthalmayr Bernhard Thalmayr
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated: