Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-17229

Authentication fails when "Agent Root URL for CDSSO" is inherited from Agent group

    XMLWordPrintable

    Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Duplicate
    • 7.0.1
    • None
    • cdsso, web agents
    • AM Sustaining Sprint 83
    • 5
    • No
    • No

      Description

      Bug description

      When the setting "Agent Root URL for CDSSO" is inherited from the Agent Group, the web agent auth flow stops working. Reverting the setting back to the individual agent (i.e when the padlock icon is unchecked) allows it to work again. The values on both the agent and group are the same.

      How to reproduce the issue

      Details steps outlining how to recreate the issue (remove this text)

      1. Set up Web Agent
      2. Create Agent Group
      3. Add Web Agent to Group
      4. Add same value for "Agent Root URL for CDSSO" to Group settings.
      5. Ensure padlock icon is locked on agent settings to inherit from group.
      6. Access the web agent
      Expected behaviour
      Reach login page and then authenticate.
      
      Current behaviour
      Error page: The redirection URI provided does not match a pre-registered value.
      

      Work around

      Using per-agent settings instead of group inherited settings.

        Attachments

          Issue Links

            Activity

              People

              kamal.sivanandam@forgerock.com Kamal Sivanandam
              darrel.nikolovski Darrel Nikolovski
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: