Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-17656

Apple Social Authentication fails when the secondary configuration is created using the wizard

    XMLWordPrintable

    Details

    • Bug
    • Status: Resolved
    • Blocker
    • Resolution: Fixed
    • 7.1.0
    • 7.1.0
    • OpenID Connect
    •  ForgeRock Access Management 7.1.0-SNAPSHOT Build b95a94d31c1583ae4f062aa33a3301f2eec7b631 (2021-March-29 15:29)
    • Rank:
      1|i046dq:
    • AM 2021.04 - Mariners Compass
    • No
    • Yes and I used the same an in the description

      Description

      Apple Social Authentication fails when the secondary configuration is created using the wizard.
      In contrast:

      • if an Apple secondary configuration exists Sign in with Apple is possible (these will disappear when AME-20499 is resolved)
      • A secondary configuration for google does not have this problem
        • One of the differences is that Sign in with Apple requires response mode form_post

      How to reproduce the issue

      Setup Sign in with Apple using a secondary configuration created using the wizard.
      These notes will help:

      Expected behaviour
      Sign in with Apple succeeds
      
      Current behaviour
      Null pointer exception (see comment below)
      

        Attachments

          Issue Links

            Activity

              People

              AndrewVinall Andrew Vinall
              AndrewVinall Andrew Vinall
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: