Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-18123

Empty authentication context breaks hosted SP

    XMLWordPrintable

    Details

    • Bug
    • Status: Open
    • Major
    • Resolution: Unresolved
    • 7.1.0, 7.0.1
    • None
    • SAML, UI
    • ForgeRock Identity cloud - Build 7.1.0-2021-3-SNAPSHOT Build 1ede77350a59d12697d1360d9b4179eee6786da2 (2021-July-09 14:22), AM 7.0.1 with Embedded DS in Global Labs
    • Rank:
      1|i05ana:
    • 8

      Description

      Bug description

      Setting authentication context level to an empty value results in SP config being unable to be viewed, with a "" For string null error being displayed when SP is accessed through XUI, and a similar error when a delete is attempted on the same SP

      How to reproduce the issue

      1. Create an ID Cloud tenant, or deploy an instance of AM
      2. Navigate to AM console
      3. Under Applications - Federation - Entity providers create a new Hosted SP, with any name and alias
      4. Edit the SP, and set a blank entry under authentication context level, removing the default 0
      5. Select update & save
      6. Observe the "" for string null error very briefly display
      7. Observe the 400 error call to https://amlocation/am/json/realms/root/realms/alpha/realm-config/saml2/hosted/dGVzdA==
      8. Navigate back to Entity providers, and select the same Entity provider again
      9. Observe the 400 error call, as well as the same error message and "Oops, Something went wrong" displayed
      10. Attempt to delete the SP from the Entity providers page
      11. Observe the same error and the 400 response code for the delete request to the same location
      Expected behaviour

      Invalid value should refuse to save, or be saved as empty string, SP should still be able to be edited and deleted

      Current behaviour

      Get and Delete requests to SP (https://am/am/json/realms/root/realms/alpha/realm-config/saml2/hosted/dGVzdA==) result in the following being returned:

      {"code":400,"reason":"Bad Request","message":"For input string: \"null\""} 
      

        Attachments

          Activity

            People

            Unassigned Unassigned
            andrew.burton Andrew Burton
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated: