Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-4183

When you delete a debug log file and re-create it openam stops logging to that file - restart of open am required.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Expired
    • Affects Version/s: 11.0.1
    • Fix Version/s: None
    • Component/s: audit logging
    • Labels:
    • Environment:
      OpenAM running on Amazon Machine Instance as part of the labs work.
    • Rank:
      1|hzojpj:

      Description

      1 – Configure OpenAM debug logging globally
      2. Clear the authentication debug file
      In a terminal window, perform the following commands:
      $ cd /home/forgerock/openam1/openam/debug
      $ echo "" > Authentication
      $ ls –l Authentication
      3. Make some logging happen.
      Logout of openam and log back in.
      Verify that logging has occured.
      4. Delete & re-create the Authentication file;
      $ rm Authentication
      $ echo "" > Authentication
      $ tail -f Authentication
      5. Try to make some more logging happen.
      Logout and login to openam again.
      This time you wont see any log entries in the Authentication file.

      If you now start and stop openam and then repeat step 5 debug will again be written to Authentication.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              JamieBowen Jamie Bowen
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: